WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 10 months ago

#28227 closed enhancement (duplicate)

Customizer: Error message instead of blank screen

Reported by: alexander.rohmann Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Customize Keywords: needs-patch
Focuses: ui, javascript Cc:

Description

When Customizer can't load due to an error, there's no indication as to what's going on. It would be nice if some information was presented instead of seeing a blank screen on the right side.

Change History (8)

#1 @celloexpressions
3 years ago

We should definitely show an error if the preview fails to load (or reload after attempting to navigate to other pages in it), probably in addition to adding something like a loading indicator. @westonruter's current work may be able to address this point.

The other possibility here is a JS error that prevents the Customizer controls from loading at all now. We'd have to have the error message loaded from PHP and shown if the Customizer controls JS stops executing due to an error, but I'm not sure that that would be as feasible.

#2 @westonruter
3 years ago

  • Focuses ui javascript added
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

#3 @westonruter
20 months ago

  • Milestone changed from Future Release to 4.6

Depends on a notification area: #35210

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


20 months ago

This ticket was mentioned in Slack in #core by chriscct7. View the logs.


18 months ago

#6 @chriscct7
18 months ago

  • Milestone changed from 4.6 to Future Release

Dependency ticket (#35210) punted to Future release. Punting this

#7 @westonruter
14 months ago

This is largely implemented now in #30937. Now when there is an error when loading the preview you'll see the error message that the server outputs (assuming you have WP_DEBUG enabled). One exception is when doing a refresh, any such error will not be shown since the refreshed iframe won't be displayed. If there is going to be a notification of an actual error even without WP_DEBUG then this will depend in part on having a notification area (#35210). Technically how the customizer will know there is an error when loading the page is that it will never receive a ready message, and thus it will know that there was a problem loading the window. This could be due to a server PHP error, or a network error, or a JS error.

Last edited 14 months ago by westonruter (previous) (diff)

#8 @westonruter
10 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22037.

Note: See TracTickets for help on using tickets.