WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#28229 closed defect (bug) (fixed)

RTL issue in plugin information tab

Reported by: ramiy Owned by: johnbillion
Milestone: 4.1 Priority: normal
Severity: normal Version: 3.9.1
Component: Plugins Keywords: has-patch
Focuses: ui, rtl, administration Cc:

Description

Found another RTL glitch in plugin information tab. I think that theme information tab also has the same problem. i didn't checked.

The "X" at top, it's aligned to the right. in RTL sites it should be aligned to the left.

Attachments (5)

upgrade-plugin-info-rtl-1.png (48.4 KB) - added by ramiy 5 years ago.
upgrade-plugin-info-rtl-2.png (76.0 KB) - added by ramiy 5 years ago.
Napkin 29-09-14 1.47.55 pm.png (179.3 KB) - added by janhenckens 5 years ago.
28229.plugin-title.png (150.0 KB) - added by SergeyBiryukov 5 years ago.
28229.diff (329 bytes) - added by janhenckens 5 years ago.

Download all attachments as: .zip

Change History (13)

#1 @janhenckens
5 years ago

  • Keywords close added

Tested this in 4.0 and in Trunk and it looks good now. Same for the theme details modal.

#2 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Plugins
  • Keywords needs-patch added; close removed
  • Milestone changed from Awaiting Review to 4.1

The issue with the Close button was fixed in the 4.0 overhaul, but I see another issue with plugin title alignment with Hebrew language files: 28229.plugin-title.png.

#3 @janhenckens
5 years ago

  • Keywords needs-patch removed

Looks like that was added to the banner image by the plugin author, see [here](http://ps.w.org/buddypress/assets/banner-772x250.png?rev=977480). Not much we can do about that.

Another think: in RTL, the Plugin label/title is always going to be over the graphic created by the plugin author. Maybe we can keep the title aligned left? Shall I also create a new ticket for this? Cause we're getting away from the close button issue.

#4 @SergeyBiryukov
5 years ago

The issue is that plugin title is not fully visible. Let's fix that in this ticket and create a new one for RTL banner images.

#5 @janhenckens
5 years ago

  • Keywords has-patch added

The issue with the plugin title only appears in FireFox, I've added a patch to fix that.

@janhenckens
5 years ago

#6 @johnbillion
5 years ago

The issue here is that the vignette background is actually too wide. Chrome handles this ok but Firefox trips up. Patch coming up.

#7 @johnbillion
5 years ago

  • Owner set to johnbillion
  • Resolution set to fixed
  • Status changed from new to closed

In 30700:

Correct the width of the background vignette in the plugin info modal.

Fixes #28229

Note: See TracTickets for help on using tickets.