WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28555 closed defect (bug) (fixed)

Bulk Actions performed when Filter button pressed

Reported by: layotte Owned by: SergeyBiryukov
Milestone: 4.0 Priority: normal
Severity: normal Version: 4.0
Component: Quick/Bulk Edit Keywords: has-patch
Focuses: ui, administration Cc:

Description

If you select a Bulk Action and then click the Filter button, it performs the Bulk Action.

http://l3w.us/images/bulk-actions.gif

Attached patch adds name to Bulk Apply button and verifies the Bulk Apply name has been passed through _REQUEST before returning current_action in class-wp-list-table.php. This seems to have fixed it for all cases in my testing.

Attachments (3)

class-wp-list-table.php.diff (1.1 KB) - added by layotte 6 years ago.
28555.diff (1.2 KB) - added by DrewAPicture 6 years ago.
regenerated + braces
28555.2.diff (3.1 KB) - added by jesin 6 years ago.
Adds name attribute to "Filter" buttons & checks it in current_action()

Download all attachments as: .zip

Change History (14)

#1 @SergeyBiryukov
6 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 4.0

@DrewAPicture
6 years ago

regenerated + braces

#2 @DrewAPicture
6 years ago

  • Keywords commit added

Confirmed. Nice catch and nice report!

class-wp-list-table.php.diff fixes it for me.

28555.diff just regenerates the patch from root with braces.

#3 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 28766:

Prevent bulk actions from being performed when Filter button is clicked.

props layotte.
fixes #28555.

#4 @iseulde
6 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

This commit is breaking plugin activation.

#6 @layotte
6 years ago

Ah, dang... looks like plugins.php is the odd man out when it comes to row-actions.

#7 @layotte
6 years ago

Looks like it messes up the "edit" row action in edit-tags.php too.

#8 @SergeyBiryukov
6 years ago

  • Keywords needs-patch added; has-patch commit removed

@jesin
6 years ago

Adds name attribute to "Filter" buttons & checks it in current_action()

#9 @jesin
6 years ago

The patch 28555.2.diff does the opposite of 28555.diff. It sets the name attribute of all filter buttons to "filter_action" and returns false in current_action() if it is present.

#10 @SergeyBiryukov
6 years ago

  • Keywords has-patch added; needs-patch removed

#11 @SergeyBiryukov
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 28916:

Prevent bulk actions from being performed when Filter button is clicked.

props jesin.
fixes #28555.

Note: See TracTickets for help on using tickets.