WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#28846 closed defect (bug) (wontfix)

switch from distraction free writer (back) to default editor doesn't work with keyboard shortcut after updating the post

Reported by: senlin Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Title basically says it all.

Switching to and from the distraction free writer works fine with the keyboard shortcut Alt + Shift + w

However when in the distraction free writer and after Updating the Post, the shortcut doesn't work anymore.

It seems for Pages nothing works, I cannot even get the Help to open there.

browser: Firefox 30.0
OS X Mavericks 10.9.4

Attachments (1)

28846.patch (677 bytes) - added by azaozz 7 years ago.

Download all attachments as: .zip

Change History (8)

#1 @senlin
7 years ago

With Chrome Pages work and show the same behaviour as described above

#2 follow-up: @azaozz
7 years ago

Yes, these shortcuts work only then the Visual editor is used and is in focus. We can add them for the "whole" page too, patch welcome :)

#3 in reply to: ↑ 2 @senlin
7 years ago

Replying to azaozz:

Yes, these shortcuts work only then the Visual editor is used and is in focus. We can add them for the "whole" page too, patch welcome :)

Perhaps you misunderstood the issue - or I misunderstand the purpose of the shortcuts ;) - the behaviour of the keyboard shortcuts is inconsistent across browsers and stops altogether after saving/updating a Post.

#4 @tellyworth
7 years ago

  • Version changed from trunk to 3.8

I can't reproduce this with FF 31.0 on OS X.

After clicking Save in the distraction free editor the alt-shift-w shortcut doesn't immediately work, but if I click focus back into the editor itself it works fine. Is that the bug, or did I misunderstand?

Either way the behaviour seems to go back to 3.8 at least.

@azaozz
7 years ago

#5 @azaozz
7 years ago

Replying to tellyworth:

Either way the behaviour seems to go back to 3.8 at least.

Right, that keyboard shortcut has never worked outside of TinyMCE. 28846.patch adds that but needs some testing with international keyboards. Also not sure if we should preventDefault() in case there is something else happening on these keys?

#6 @senlin
7 years ago

The patch solves the issue for me.

#7 @iseulde
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

DFW mode has changed in 4.1.

Note: See TracTickets for help on using tickets.