WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#29331 closed defect (bug) (fixed)

Blank line is inserted when paragraphs are merged

Reported by: Moshe1010 Owned by:
Milestone: 4.2 Priority: normal
Severity: minor Version: 3.9
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Hello,

This bug is present also in WP4 B4. I'm using Chrome 36, OSX or Windows.
It goes like this:

  1. Write 3 different sentences and separate each one with SHIFT+ENTER (twice) or one Enter
  2. Go to the 3rd sentence and bring it up to the 2nd sentence (by deleting one character at the beginning of the 3rd sentence).
  3. Then press Shift + Enter to make no space in between the sentences
  4. Then do steps 1+2 for the 2nd sentence
  5. The result is a space created between the 3rd and 4th sentence

See the following Gif for more details:
http://imageshack.com/a/img902/9991/1qSkL3.gif

Thanks.

Change History (9)

#1 @knutsp
7 years ago

  • Component changed from Editor to TinyMCE
  • Severity changed from normal to minor
  • Summary changed from Space is created when bringing one phrase up... to Blank line is inserted when paragraphs are merged

Confirmed for Chrome, in beta4. Does not happen with Firefox or IE11.

#2 @azaozz
7 years ago

  • Keywords close added

Still happens in 4.1 trunk. Looks like a long standing WebKit/Blink bug with merging paragraphs with the backspace key. Don't think we can do anything about it. The workaround is to merge from top to bottom, then it works properly.

#3 follow-up: @iseulde
7 years ago

  • Keywords reporter-feedback added
  • Version changed from 3.9.2 to 3.9

I have a hard time reproducing this, but maybe I'm doing it wrong. Is this still an issue? Simpler steps would be appreciated. :)

#4 in reply to: ↑ 3 @Moshe1010
7 years ago

Replying to avryl:

I have a hard time reproducing this, but maybe I'm doing it wrong. Is this still an issue? Simpler steps would be appreciated. :)

Start writing a new post

  1. Write 3 sentences with ENTER key b/w them
  2. Backspace the 3rd line to eliminate the space b/w the 2nd and 3rd row with SHIFT + ENTER
  3. Do the same thing b/w 1st and 2nd row

See the attached gif:
http://imagizer.imageshack.us/a/img902/9991/1qSkL3.gif

#5 @iseulde
6 years ago

  • Keywords reporter-feedback removed

I tried again and now I can reproduce. :)
Simpler steps: type 'one', ENTER, 'two', SHIFT+ENTER, 'three'. Place the cursor before 'two, and BACKSPACE.
This is something for TinyMCE to fix. I'll ping them.

#6 @iseulde
6 years ago

Done.

#7 @iseulde
6 years ago

This was great timing. :) They'll look into it.

Will fix this in the upcoming patch. Since I will work on exactly that part of the code merging paragraphs tomorrow due to another issue.

#8 @iseulde
6 years ago

  • Milestone changed from Awaiting Review to 4.2

#9 @iseulde
6 years ago

  • Keywords close removed
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [31700], see #31551.

Note: See TracTickets for help on using tickets.