WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29375 closed defect (bug) (duplicate)

When publishing a non-public post type post

Reported by: slobodanmanic Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Posts, Post Types Keywords: has-patch
Focuses: administration Cc:

Description (last modified by SergeyBiryukov)

A similar problem was fixed in [24799] (removes preview button for non-public post types), but when you first publish a non-public post there's still that "Post published. View post" notice.

http://cl.ly/image/1J0v2m0Q1S3H/Screen%20Shot%202014-08-26%20at%2010.59.06%20AM.png

Attachments (2)

29375.diff (2.7 KB) - added by slobodanmanic 7 years ago.
29375.2.diff (2.7 KB) - added by DrewAPicture 7 years ago.

Download all attachments as: .zip

Change History (9)

#1 @slobodanmanic
7 years ago

Same problem with "Post updated", "Post draft updated" "Post submitted" and "Post scheduled for:", working on a patch for this.

Last edited 7 years ago by slobodanmanic (previous) (diff)

@slobodanmanic
7 years ago

#2 @slobodanmanic
7 years ago

This fixes the issue, but there's some duplicate code, I'd love to hear a second opinion on it.

@DrewAPicture
7 years ago

#3 @DrewAPicture
7 years ago

  • Focuses administration added
  • Keywords has-patch added

Hi, thanks for the ticket. This issue has been raised several times before in other tickets, though in #17609 it was suggested to create a new ticket for updating these messages. This should suffice.

I think @jfarthing84 makes a good point in comment:33:ticket:17609 in that we should probably be checking publicly_queryable instead of public as the former is really what we're dealing with. And if publicly_queryable isn't set, it falls back to the value of public anyway.

29375.2.diff addresses your DRY concerns.

Related: #17609.

#4 @helen
7 years ago

  • Version trunk deleted

#5 @johnbillion
7 years ago

  • Version set to 3.0

#6 @johnbillion
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is still a dupe of #17609. Let's keep the conversation in one place.

#7 @SergeyBiryukov
7 years ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.