WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

Last modified 4 years ago

#29640 closed defect (bug) (wontfix)

Pages sorted by date: No hierarchy dashes

Reported by: let me see... Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description (last modified by SergeyBiryukov)

When I sort my pages by date, the hierarchy dashes disappear.

Attachments (2)

before.png (992.5 KB) - added by collinsinternet 7 years ago.
Pages - Before Sort By Date
after.png (1.0 MB) - added by collinsinternet 7 years ago.
Pages - After Sort By Date

Download all attachments as: .zip

Change History (11)

#1 @johnbillion
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

WordPress doesn't support parent/child relationships between sites, therefore this functionality must be provided by a plugin on your site. Please report these issues to the author of the plugin.

#2 @let me see...
7 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

John, I meant pages, not sites. Wrong translation from German... reopened the ticket.

#3 @SergeyBiryukov
7 years ago

  • Component changed from General to Posts, Post Types
  • Description modified (diff)
  • Focuses administration added
  • Milestone set to Awaiting Review
  • Summary changed from Sites sorted by date: No hierarchy dashes to Pages sorted by date: No hierarchy dashes

Confirmed.

#4 @let me see...
7 years ago

gracias!

@collinsinternet
7 years ago

Pages - Before Sort By Date

@collinsinternet
7 years ago

Pages - After Sort By Date

#5 @collinsinternet
7 years ago

  • Keywords dev-feedback 2nd-opinion added

This is confirmed as well.

However, can we consider this as a defect since the sort by date does exactly what it is supposed to do which is ordered by date instead of parent/child hierarchy?

#6 @helen
7 years ago

Dashes seem like they'd be meaningless when not in a sort order that respects hierarchy. Some kind of alternative display for page parents would be worth exploring (breadcrumb trail or some other kind of string), there have been some other times I've noticed that would be useful.

#7 @swissspidy
6 years ago

  • Keywords close added; dev-feedback 2nd-opinion removed

Suggesting closing as wontfix.

An alternative approach as mentioned by Helen seems best. This can happen outside of a regular release cycle, e.g. in a feature plugin.

#8 @SergeyBiryukov
5 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from reopened to closed

#9 @tazotodua
4 years ago

dashes will be good, although,waht @helen said,i might not agree fully,
because i might have pages:

pages/jesika
and
pages/neoghbors/jesika

and one dash and two dashes will give me some hint/

Note: See TracTickets for help on using tickets.