WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#29994 closed defect (bug) (fixed)

Border bug on empty list tables on small screens

Reported by: pento Owned by:
Milestone: 4.3 Priority: normal
Severity: minor Version:
Component: Administration Keywords: make-flow has-patch
Focuses: ui, administration Cc:
PR Number:

Description

When you have an empty list table, the small screen view has a border bug on the "No items found" cell.

This is caused by columns being hidden in the small screen view, but the colspan for this cell isn't updated appropriately.

Attachments (3)

IMG_2914.png (59.7 KB) - added by pento 5 years ago.
29994.diff (6.1 KB) - added by kevdotbadger 5 years ago.
IMG_4350.PNG (150.8 KB) - added by ryan 4 years ago.
Fixed

Download all attachments as: .zip

Change History (10)

@pento
5 years ago

#1 @soficgr
5 years ago

the problem exists because is hide one <th> description th is display:none;

#2 @soficgr
5 years ago

  • Severity changed from normal to minor

@kevdotbadger
5 years ago

#3 @kevdotbadger
5 years ago

Looking at this, does colspanchange (defined in wp-admin/common.js) actually do anything? It's not really used anywhere and removing the code doesn't seem to effect anything? My patch works, but it's very tag only. Perhaps a refactor of colspanchange is needed?

#4 @bradt
5 years ago

  • Keywords has-patch added

#5 @ryan
5 years ago

On an iPhone 6+, this helped with the Tags screen but not with the comments screen. They could be separate issues, however. The comments screen is getting some related work in #29991.

This ticket was mentioned in Slack in #core-flow by boren. View the logs.


5 years ago

@ryan
4 years ago

Fixed

#7 @ryan
4 years ago

  • Milestone changed from Awaiting Review to 4.3
  • Resolution set to fixed
  • Status changed from new to closed

Fixed by the work on #32395.

Note: See TracTickets for help on using tickets.