WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#30067 closed defect (bug) (invalid)

cookie error for multisite login

Reported by: tezza71 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: reporter-feedback
Focuses: multisite Cc:

Description

I have a multisite with a few sites set up where I have no problems logging in.

I just added a new domain/site so there are no cookies in my browsers for that domain, and I am using the default theme (2014). This is the first site I have added since upgrading to 4.0.

When attempting to login, I get the "Cookies are blocked" error.

I know the credentials are good, and I have tried with with both firefox and internet explorer on separate computers, each browser with extensions disabled. I followed the instructions on the firefox page to make sure cookies are enabled.

I disabled all the plugins on my WP multisite (network deactivate) but this has not helped. I also temporarily renamed the plugins folder for and tested again.

I am accessing it from a home network with no special proxies to go through, and I can confirm that there are plenty of other cookies in my firefox browser, some of which are for the other domains in my multisite installation for which I remain successfully logged in.

I have put this up for discussion in the forums, but no one seems to have any ideas. https://wordpress.org/support/topic/login-cookie-error-multisite

  • I have eliminated the Broswer (or browser extensions) as the source of the problem.
  • I have eliminated WP plugins or custom themes as the source.
  • No network conditions such as proxies have prevented any of the other domains/sites - from being logged in to.
  • The site front-end shows up in the 2014 theme no problems at all.

Change History (8)

#1 @SergeyBiryukov
6 years ago

Does the error message mention unexpected output? There are two typical reasons for that:

  1. One of the active plugins (or the theme's functions.php file) produces unexpected output, causing a "headers already sent" warning and consequently preventing WordPress from setting the test cookie.
  2. UTF-8 byte order mark in wp-config.php (or theme's functions.php file) has the same effect as above.

You should be able to find out the culprit by looking into server error logs.

Previously: #27974, #28490.

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#2 follow-up: @tezza71
6 years ago

  • Severity changed from normal to blocker

It does not say anything about "headers already sent". The entire error is;
"ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

I am using the 2014 theme and the error is produced with ALL plugins deactivated.

Nothing shows up in the error log, and the access log looks normal.

ACCESS LOG:

60.241.56.76 - - [29/Oct/2014:01:48:26 +0000] "GET /wp-login.php HTTP/1.1" 200 1149 "http://r2b.cc/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
60.241.56.76 - - [29/Oct/2014:01:48:26 +0000] "GET /wp-includes/css/buttons.min.css?ver=4.0 HTTP/1.1" 304 0 "http://r2b.cc/wp-login.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
60.241.56.76 - - [29/Oct/2014:01:48:27 +0000] "GET /wp-includes/css/dashicons.min.css?ver=4.0 HTTP/1.1" 304 0 "http://r2b.cc/wp-login.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
60.241.56.76 - - [29/Oct/2014:01:48:27 +0000] "GET /wp-admin/css/login.min.css?ver=4.0 HTTP/1.1" 304 0 "http://r2b.cc/wp-login.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
60.241.56.76 - - [29/Oct/2014:01:48:27 +0000] "GET /wp-admin/images/wordpress-logo.svg?ver=20131107 HTTP/1.1" 304 0 "http://r2b.cc/wp-admin/css/login.min.css?ver=4.0" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"
60.241.56.76 - - [29/Oct/2014:01:48:29 +0000] "POST /wp-login.php HTTP/1.1" 200 1264 "http://r2b.cc/wp-login.php" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:33.0) Gecko/20100101 Firefox/33.0"

Someone else has posted that they are having the same problem with their multisite installation.

https://wordpress.org/support/topic/login-cookie-error-multisite?replies=7#post-6166162

I have set the severity to 'blocker' since one cannot create content for the site without it being solved. All one can do is create an empty site - which is of course pointless without content.

#3 @johnbillion
6 years ago

  • Keywords reporter-feedback added

Are you using domain mapping on the network? Are you using SSL anywhere?

Possibly related: #29641

#4 @knutsp
6 years ago

  • Severity changed from blocker to normal

Is this still a problem after restarting your browser, plus deleting all cookies, and trying with another browser, may be from another unit or location? Must ask, since for me and the clients I support, when such problems arise, the browser is the problem. Firefox is the browser that most often gets overloaded with cookies and for some odd reason refuses to accept more.

No need to set this ticket as a blocker until it's recognized as a core defect and given the next milestone.

#5 @jeremyfelt
6 years ago

  • Focuses multisite added

#6 in reply to: ↑ 2 @SergeyBiryukov
6 years ago

Replying to tezza71:

It does not say anything about "headers already sent". The entire error is;
"ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress."

Some other possible reasons from #27373:

#7 @jeremyfelt
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.0 deleted

I'm going to close this out as "invalid" only because we don't have a way to reproduce yet. Please re-open if necessary.

#8 @honyczek
5 years ago

@SergeyBiryukov thanks for suggestions. I had the same problem with Cookies message in Internet Explorer. After reading your post, where you mentioned Cookie specification, it lead to successful solution. I experimented with DNS records, if it depends in type of record (A or CNAME), but the last thing, which I didn't expect was underscore in DNS name, which i had to replace with minus sign. And then Cookies in IE were all right.

Note: See TracTickets for help on using tickets.