WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 4 years ago

#30374 closed defect (bug) (wontfix)

Twenty Fifteen: Lack of list indentation

Reported by: aprea Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

The HTML list items appear outside of the bounds of the main content area for posts/pages (see attached image).

Not sure if this is an intentional design decision but it seems inconsistent with the way prior default themes have styled their list items, see http://twentyfourteendemo.wordpress.com/html-elements/

Attachments (4)

twenty-fifteen-lists.PNG (12.5 KB) - added by aprea 6 years ago.
30374-ol.PNG (23.9 KB) - added by jcastaneda 6 years ago.
30374-ul.PNG (23.2 KB) - added by jcastaneda 6 years ago.
twenty-fifteen-lists-2.png (34.8 KB) - added by aprea 6 years ago.

Download all attachments as: .zip

Change History (12)

#1 @aprea
6 years ago

  • Summary changed from Twenty Fifteen: Odd list alignment to Twenty Fifteen: Lack of list indentation

@jcastaneda
6 years ago

@jcastaneda
6 years ago

#2 @jcastaneda
6 years ago

Are you running the latest version of the theme? Are you on trunk? The images I've included show it with the latest version of trunk.

#3 @aprea
6 years ago

Yeah, I'm not talking about nesting, I'm talking about the base indentation. See image below, the top half is the current trunk and the bottom half is what I'm expecting lists to look like.

Again, this could simply be a design decision, it just seems inconsistent with how lists are typically styled.

As an example, Bootstrap add a left indent to lists, see http://getbootstrap.com/css/#type-lists

#4 @afercia
6 years ago

The theme designers can answer better than me but as far as I know, yes, this is indeed by design and it's called
hanging punctuation

#5 @iamtakashi
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

As afercia mentioned, Twenty Fifteen is designed to use the hanging punctuation on medium and large screen size to maintain the better flow of reading experience.

Last edited 6 years ago by iamtakashi (previous) (diff)

This ticket was mentioned in Slack in #core-themes by jcastaneda. View the logs.


6 years ago

#7 @ocean90
6 years ago

#30621 was marked as a duplicate.

This ticket was mentioned in Slack in #polyglots by ocean90. View the logs.


4 years ago

Note: See TracTickets for help on using tickets.