WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#30405 closed defect (bug) (invalid)

WordPress Beta Tester Plugin Broken + svn trunk update also fails

Reported by: dfavor Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

The WordPress Beta Tester plugin (as of this moment) pulls 4.0.1-alpha instead of 4.1-beta so is useless.

This also fails to pull latest beta.

cd wordpress-install-root
svn checkout --force http://core.svn.wordpress.org/trunk/ .
chown -hR www-data:www-data .
svn up
navigate to http://site/wp-admin/upgrade.php

The result is a 4.0 install, instead of 4.1-beta or rather a partial 4.0 + 4.1 install where new files in 4.1 (like Twenty Fifteen Theme) are installed + existing files (like readme.html + core files) aren't updated.

Please detail exact steps to upgrade a 4.0 install to 4.1-beta using svn commands.

Thanks.

Change History (11)

#1 @kpdesign
5 years ago

  • Type changed from enhancement to defect (bug)

SVN works for me for latest trunk (both new checkouts and updating existing ones), but my local installs running bleeding edge nightlies via the Beta Tester plugin are not updating as of today.

Clarification: My local installs are not auto-updating - I have not tried a manual update using the Update Now button.

Last edited 5 years ago by kpdesign (previous) (diff)

This ticket was mentioned in Slack in #core by johnbillion. View the logs.


5 years ago

#3 @morganestes
5 years ago

dfavor: This looks like two separate issues you're working with:

  1. Beta Tester plugin not updating to the most recent version
  2. Can't update to 4.1-beta1 with SVN

I see that you opened a support request for the Beta Tester plugin, so I'm going to suggest that be the canonical reference for that issue and leave this ticket open for the second issue.

For the SVN issue, I've gone through the steps to clone trunk and issue svn up right after. The version installed right now is 4.1-beta1 in both those cases. Are you saying that the version changes to 4.0 when you update via the admin page after you clone trunk? Is this on a clean install of trunk, or one that was previously a stable version that was upgraded to trunk?

#4 @dd32
5 years ago

In 30411:

Bump the $wp_version.
This version string controls more than you might first imagine, but the important thing to note for now, is that this needs to contain a revision number in order for nightly builds to include a revision number.
If a nightly build doesn't include a revision number, Background Updates won't occur for Development users (after all, 4.1-beta1 == 4.1-beta1, which is already installed).
See #30405

#5 @dd32
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

FWIW, it looks like the Beta Tester plugin is working as intended, it's likely that the plugin was configured for 4.0.1 releases on it's configuration page though - I've replied to your support forum thread.

As for SVN, well, SVN works fine. I'm not sure why your commands failed, but I'd suggest removing the old files and overwriting them with the new ones. It's also possible it's a filesystem / php caching issue, so restarting the php processes could help.

Clarification: My local installs are not auto-updating - I have not tried a manual update using the Update Now button.

This is yet another different issue, Since the nightly builds have been all using the same version identifier (4.1-beta1) the updates have been skipping it (after all, why update if it's already running it?).
[30411] fixes it by simply putting a revision number in there, the next nightly build will be fixed.. Although it'll probably be beta2, and would've updated anyway. I've added this commit simply to point out the 'requirement' :)

#6 @dfavor
5 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

To clarify/simplify.

Please detail exact steps to upgrade a 4.0 install to 4.1-beta using svn commands.

Lots of comments above. No list of correct commands to accomplish what I asked.

#7 @dfavor
5 years ago

http://codex.wordpress.org/Using_Subversion should really contain this information.

Seems like this would be a common question to answer, since the WordPress Beta Tester plugin rarely seems to work, based on my past experience + reading plugin tickets.

#8 @dfavor
5 years ago

Ugly workaround that seems to work.

1) cd to directory above wordpress

2) mv wordpress wordpress.bak

3) wget wordpress.org/nightly-builds/wordpress-latest.zip

4) unzip wordpress-latest.zip

5) cp wordpress.bak/wp-config.php wordpress/.

6) navigate to http://$site/wp-admin/upgrade.php

Database update runs. New version 4.1-beta now shows up.

#9 @dfavor
5 years ago

Well... This does mean you have to reinstall all your plugins + themes, as they'll be blown away.

So... this method ain't for the faint of heart.

#10 @dd32
5 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

The exact same SVN commands you'd use anywhere.

If it's not an existing SVN checkout, you can use, as posted in your ticket:
svn checkout --force http://core.svn.wordpress.org/trunk/ .

If it's an existing SVN checkout, you can switch to trunk:
svn switch https://core.svn.wordpress.org/trunk/ .

If it's something else, you can just overwrite all the files by creating an export and not creating a SVN checkout:
svn export --force https://core.svn.wordpress.org/trunk/ .

Trac is not for support requests, we have some support forums which can guide you through non-code bug reports.

#11 @dfavor
5 years ago

Be good if http://codex.wordpress.org/Using_Subversion had info from last update.

Note: See TracTickets for help on using tickets.