WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#30427 closed defect (bug) (invalid)

New WP 4.0.1 HTTPS Issue

Reported by: jhirschi Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0.1
Component: General Keywords: reporter-feedback
Focuses: administration Cc:

Description

Wordpress 4.0 caused redirect loops on test.sunsetvistarealty.com, which has:
Wordpress Address (URL): https://test.sunsetvistarealty.com
Site Address (URL): https://test.sunsetvistarealty.com

WP 4.0.1 fixed the redirect loops, buy now I'm getting Mixed Content errors:
The page at 'https://test.sunsetvistarealty.com/search/' was loaded over HTTPS, but requested an insecure script 'http://test.sunsetvistarealty.com/wp-content/plugins/svr_hans_grandchild/svr_hans_grandchild-scripts.js?ver=1.0'. This request has been blocked; the content must be served over HTTPS.

I thought a Wordpress URL and Site URL set to HTTPS was supposed to force all content to be loaded as HTTPS.

Change History (6)

#1 @SergeyBiryukov
6 years ago

Are you using wp_enqueue_script() to load the svr_hans_grandchild-scripts.js file?

#2 @jhirschi
6 years ago

Yup:

function svr_grandchild_add_scripts() {
    wp_register_script( 'svr_hans_grandchild-script', plugins_url( 'svr_hans_grandchild-scripts.js', __FILE__ ), array( 'jquery' ), '1.0' );
    wp_enqueue_script( 'svr_hans_grandchild-script' );
}
add_action( 'wp_enqueue_scripts', 'svr_grandchild_add_scripts', 11 );
Last edited 6 years ago by ocean90 (previous) (diff)

#3 @johnbillion
6 years ago

  • Keywords reporter-feedback added

I'm unable to reproduce this issue. The enqueued file has the correct https scheme.

Can you reproduce the issue with all your other plugins deactivated and the default theme (eg Twenty Fourteen or Twenty Fifteen) enabled? Can you reproduce this issue with just this piece of code isolated on its own?

#4 @jhirschi
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Stripped it down to theme Twenty Fourteen and all plugins deactivated: problem disappeared.
Put it back together one plugin at a time and found offending plugin.
Problem solved.
Sorry to have taken up your time, but thank you for your response.

#5 @DrewAPicture
6 years ago

  • Milestone Awaiting Review deleted

Hi jhirschi,

Would you mind telling us the name of the offending plugin?

#6 @jhirschi
6 years ago

It's a homegrown one.

Note: See TracTickets for help on using tickets.