WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#30607 closed defect (bug) (duplicate)

Errors in function retrieve_password

Reported by: diegofranca90 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0.1
Component: Login and Registration Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by TobiasBg)

The functions have duplicate do_action('retrieve_password'), on lines 312 and 320.

Error on line 363, the link is incorrect:

$message .= '<' . network_site_url("wp-login.php?action=rp&key=$key&login=" . rawurlencode($user_login), 'login') . ">\r\n";

I hope have helped and sorry my bad english, I'm brazilian.

Change History (4)

#1 @TobiasBg
2 years ago

  • Keywords reporter-feedback added

Hi @diegofranca90,

thanks for your report and for contributing to WordPress!

The first issue that you describe is not actually a bug: Note the difference between the two lines. In the first one, it's "retreive_password" (with "ei"), where it's "retrieve_password" (with "ie") in the second. To not run into backwards compatibility issues, both of the action hooks are being kept.

For your second issue: Can you please explain what is incorrect about that link? (Note that it's actually not a link for a website (with an <a> HTML tag), but a link/URL in an email.) Thanks!

#2 @TobiasBg
2 years ago

  • Description modified (diff)

#3 @diegofranca90
2 years ago

When I get the email gmail or browser interprets as an unknown tag and is not displayed in the code is < and not &lt;

And sorry I did not notice the small difference in actions :P

#4 @TobiasBg
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the clarification! That issue has been discussed in two other tickets, so that we can close this one as a duplicate of them: #21095 and #23420.
I suggest that you check the suggestions in those tickets.

Note: See TracTickets for help on using tickets.