WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30632 closed defect (bug) (fixed)

Twenty Fifteen theme jumping error

Reported by: kidsguide Owned by: iandstewart
Milestone: 4.1 Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords: has-patch commit
Focuses: Cc:
PR Number:

Description (last modified by ocean90)

In the Twenty Fifteen theme, there is a wired jumping error when you scroll to the bottom of the page. Check out the video below.

https://www.youtube.com/watch?v=3O73MC36Cc0

I am using the following:

  • Windows 7
  • A fresh install of WordPress 4.1 beta2
  • Internet Explorer (the error does not happen on Firefox)

Attachments (2)

30632.diff (2.0 KB) - added by iamtakashi 5 years ago.
30632.2.diff (2.0 KB) - added by ocean90 5 years ago.

Download all attachments as: .zip

Change History (23)

#2 @kidsguide
5 years ago

  • Version set to trunk

#3 @ocean90
5 years ago

  • Description modified (diff)

Related: ticket:30366:26

#4 @iamtakashi
5 years ago

What version is the IE? I can't replicate it with IE11 in Windows 8.

#5 @iamtakashi
5 years ago

Correction: I managed to replicate the issue with IE11 on Windows 8 also. Investigating.

#6 @iamtakashi
5 years ago

  • Keywords needs-patch added

#7 @kidsguide
5 years ago

I am using IE11 in Windows 7.

#8 @iamtakashi
5 years ago

It's weird. For some reason, when the sidebar is longer than the main content, the height of document is 1px taller than the sidebar in IE... It should be the same height.

#9 @kidsguide
5 years ago

It is a very strange error. Hopefully we can figure it out.

#10 @iamtakashi
5 years ago

With a quick search, it looks like $( document ).height() doesn't always give you a cross browser, pixel accurate height. What about checking the body height instead? As far as I test, it works fine but I'd like to hear second opinions and needs more test.

@iamtakashi
5 years ago

#11 @iamtakashi
5 years ago

  • Keywords has-patch 2nd-opinion needs-testing added; needs-patch removed

#12 @kidsguide
5 years ago

Just tested your diff, and it works.

#13 @iandstewart
5 years ago

  • Milestone changed from Awaiting Review to 4.1

This ticket was mentioned in Slack in #core by iandstewart. View the logs.


5 years ago

#15 @cainm
5 years ago

+1 on the diff

#16 @iamtakashi
5 years ago

Noting here that 30632.diff will also fix #30645.

#17 @kidsguide
5 years ago

Great!

#18 @kidsguide
5 years ago

  • Keywords dev-feedback added

@ocean90
5 years ago

#19 @ocean90
5 years ago

  • Keywords commit added; 2nd-opinion needs-testing dev-feedback removed

I can confirm that 30632.diff will fix this ticket and #30645.

30632.2.diff also replaces $( 'body' ) with $( document.body ) which is faster.

#20 @iandstewart
5 years ago

@cainm and @ocean90 thanks for the feedback.

#21 @iandstewart
5 years ago

  • Owner set to iandstewart
  • Resolution set to fixed
  • Status changed from new to closed

In 30808:

Twenty Fifteen: correcting odd scrolling and jumping in IE and no-scroll with window resize.

Props iamtakashi, ocean90, fixes #30632, #30645.

Note: See TracTickets for help on using tickets.