WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#30954 closed defect (bug) (fixed)

Allow <s> tags in addition to <strike> in title

Reported by: paulschreiber Owned by: wonderboymusic
Milestone: 4.2 Priority: normal
Severity: normal Version: 4.2
Component: Formatting Keywords: has-patch kses
Focuses: Cc:

Description

Currently, WordPress allows the <strike> tag, which is deprecated/obsolete, but not the <s> tag, which is supported in HTML5:

https://developer.mozilla.org/en-US/docs/Web/HTML/Element/strike
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/s

Attachments (2)

30954.patch (313 bytes) - added by paulschreiber 7 years ago.
paines-temas-sobre.png (90.4 KB) - added by TAPANDAS 7 years ago.

Download all attachments as: .zip

Change History (10)

#1 @helen
7 years ago

  • Keywords reporter-feedback added
  • Type changed from defect (bug) to enhancement
  • Version changed from trunk to 4.0

What does "WordPress allows" mean, exactly? kses, TinyMCE, something else?

#2 @paulschreiber
7 years ago

  • Keywords reporter-feedback removed
  • Summary changed from Allow <s> tags in addition to <strike> to Allow <s> tags in addition to <strike> in title
  • Type changed from enhancement to defect (bug)
  • Version changed from 4.0 to trunk

To clarify, I'm referring to the post_title field. The post_content already allows both tags.

@paulschreiber
7 years ago

#3 @paulschreiber
7 years ago

It looks like this is in kses' $allowedtags array. I've attached a patch.

#4 @paulschreiber
7 years ago

  • Keywords has-patch added

#5 @SergeyBiryukov
7 years ago

  • Component changed from General to Formatting

Confirmed. We have <s> in $allowedposttags, but not in $allowedtags.

30954.patch works as expected.

#6 @miqrogroove
7 years ago

  • Keywords kses added

I couldn't remember if there was a ticket for general kses modernization. I will tag some of these tickets so they are easier to find or group together.

#7 @wonderboymusic
7 years ago

  • Milestone changed from Awaiting Review to 4.2

#8 @wonderboymusic
7 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 31205:

Add <s> to $allowedtags in KSES.

From https://developer.mozilla.org/en-US/docs/Web/HTML/Element/s :
"The <strike> element, alter ego of the <s> element is obsolete and should not be used on Web sites any more."

<strike> shall remain for BC, but <s> should not be stripped from the author (et al) role's HTML input.

Props paulschreiber.
Fixes #30954.

Note: See TracTickets for help on using tickets.