Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#31380 closed defect (bug) (worksforme)

Twenty Fifteen: Safari visualization bug

Reported by: marcie73 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords: close
Focuses: Cc:


I can see a visualization problem with Safari. It must a bug since it is not showing that in other browsers . The white left sidebar is narrower and the content in it goes outside. I can see that the problem is not depending from the sidebar element but from somethimg else. The header is actually on top of the sidebar, so I don't really understand in which element goes the background (the one you set from the theme options related to Header) which is taking all the height of the left column. The element cannot be inspected, it seems not existing.
Please I cannot figure out how to fix it in the css. Please help!!
Attached screenshot. Thank you

Attachments (2)

screenshot-bug.png (668.5 KB) - added by marcie73 3 years ago.
mysite-bug.png (915.1 KB) - added by marcie73 3 years ago.

Download all attachments as: .zip

Change History (8)

#1 @SergeyBiryukov
3 years ago

  • Component changed from Themes to Bundled Theme
  • Summary changed from Safari visualization bug twentyfifteen theme to Twenty Fifteen: Safari visualization bug

#2 @lancewillett
3 years ago

  • Keywords reporter-feedback added

Hi marcie73, welcome. Could you provide a bit more info?

  • Do you have a live site URL to check?
  • Are any plugins activated? Does this happen with zero plugins installed?
  • Have you made modifications to Twenty Fifteen at all?

3 years ago

#3 @marcie73
3 years ago

Hello! thank you very much for your quick answer. In the meantime I was waiting for you I did a further check noticing that the problem shows in Safari until version 5. Since being quite an old version, I don't know if this bug is still worth to be fixed, anyway I would be curious to know why it is happening.
The problem shows in the original theme(without customization), at https://twentyfifteendemo.wordpress.com/
Of course I used twentyfifteen as base for a customized site, and I noticed the problem only once I finished it (before I tested it in chrome, firefox, iphone, ipad....). My site is:
Im my site you can see a gray line crossing vertically the header/sidebar and the backgroud stops there. Anyway in the original theme preview is more evident. I uploaded both screenshots. Thank you very much.

#4 @lancewillett
3 years ago

  • Keywords close added; reporter-feedback removed

Thanks for the clarification. For Safari browser support we generally say last major version and one back, so 7.0 would be what we target (and higher) since current major version is 8.0.

I suggest closing — acknowledging it but deciding not to spend time on it.

#5 @marcie73
3 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

You are right. I spent enough time on it. Thank you Lancewillet for your reply and attention.

#6 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.