WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#31660 closed defect (bug) (fixed)

Press This: some images don't get "sideloaded"

Reported by: azaozz Owned by: azaozz
Milestone: 4.2 Priority: normal
Severity: normal Version: 4.2
Component: Press This Keywords:
Focuses: Cc:

Description

Seems caused by slashes in post_content. We are looking at the POST which is slashed, need to strip slashes, run WP_Press_This::side_load_images(), then add slashes again.

Change History (1)

#1 @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 31799:

Press This:

  • Strip slashes while running side_load_images(), add slashes after.
  • Simplify and clean up side_load_images().
  • Add another arg to media_sideload_image() to return the uploaded image src only, and fix it to always return WP_Error on errors.

Fixes #31660.

Note: See TracTickets for help on using tickets.