Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#3185 closed defect (bug) (duplicate)

options.php saves nonce fields and Submit button value

Reported by: donncha Owned by: rboren
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: General Keywords: options nonce
Focuses: Cc:


If you edit the options of a blog directly through options.php it will add options for Update, Wpnonce, and Wp_http_referer. This is because $_POSTpage_options? doesn't exist.

To fix: add each element of the form to an array and run through that array when updating, or just check for the nonce fields.

Change History (3)

comment:1 @markjaquith9 years ago

Related (duplicate?): #2595

comment:2 @markjaquith9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2595

comment:3 @Nazgul8 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.