WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#31940 closed defect (bug) (duplicate)

Suppressed fatal error in WP_Image_Editor_GD class

Reported by: nevma Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1.1
Component: Media Keywords:
Focuses: Cc:
PR Number:

Description

Class: WP_Image_Editor_GD
File: wp-includes/class-wp-image-editor-gd.php
Method: load()
Line: 102
Exact code: $this->image = @imagecreatefromstring( file_get_contents( $this->file ) );

When processing large images, there is the possibility for the memory to get exhausted. In that case, the execution just stops without any notification.

While this is not a bug in terms of data handling, the reason of a fatal PHP error should probably be somehow communicated.

Change History (1)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23127 and #31879.

Note: See TracTickets for help on using tickets.