Make WordPress Core

Opened 9 years ago

Closed 9 years ago

#32030 closed defect (bug) (invalid)

4.2 About Page video loading icons are overflowing container

Reported by: kelderic's profile Kelderic Owned by: wonderboymusic's profile wonderboymusic
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Embeds Keywords: dev-feedback close
Focuses: Cc:

Description

Summary

The animated loading icons for the videos on the 4.2 about page overflow their containers. They are set to 640px in width, while the container is 315px in width.

Steps to Reproduce

  • Log in to WP Admin.
  • Go to About Page (/about.php)
  • Scroll Down to the 3 column video section.

Attachments (3)

wp4.2_aboutpage_videoloadingoverflow.png (190.7 KB) - added by Kelderic 9 years ago.
Screenshot of issue.
32030.diff (508 bytes) - added by dipesh.kakadiya 9 years ago.
Add backgroup colot to play button because it is not visibble due to transparent background
32030.2.diff (876 bytes) - added by SergeyBiryukov 9 years ago.

Download all attachments as: .zip

Change History (11)

@Kelderic
9 years ago

Screenshot of issue.

#1 @Kelderic
9 years ago

Sorry, forgot to mention, I'm running Windows 7, Firefox 37.0.1.

On Chrome, it appears that instead of width:640px, width is being set to 100%. Same with IE11.

#2 @SergeyBiryukov
9 years ago

  • Component changed from Upgrade/Install to Help/About
  • Milestone changed from Awaiting Review to 4.2

This ticket was mentioned in Slack in #core by drew. View the logs.


9 years ago

#4 @DrewAPicture
9 years ago

  • Component changed from Help/About to Embeds
  • Keywords dev-feedback added
  • Milestone changed from 4.2 to Future Release
  • Owner set to wonderboymusic
  • Status changed from new to assigned

Moving off the milestone as these videos are just placeholders for now. We should probably look at why the loading icon is being offset in mediaelement video embeds though.

@wonderboymusic: Mind taking a look when you have a chance?

#5 @DrewAPicture
9 years ago

#32046 was marked as a duplicate.

@dipesh.kakadiya
9 years ago

Add backgroup colot to play button because it is not visibble due to transparent background

#6 @SergeyBiryukov
9 years ago

  • Keywords close added

The issue is caused by missing width in the wp_video_shortcode() call.

32030.2.diff fixes that, but since these are just placeholders, I'd suggest closing the ticket as invalid.

This wasn't an issue in 3.9 or 4.0, because the width was specified in both.

#7 @dipesh.kakadiya
9 years ago

@SergeyBiryukov

I think width is different for every theme so it better to add CSS and fixed it. i already submitted CSS patch https://core.trac.wordpress.org/attachment/ticket/32030/32030.diff.
I tested with all core Wordpress theme it's working fine.

Last edited 9 years ago by dipesh.kakadiya (previous) (diff)

#8 @helen
9 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from assigned to closed

If this is visibly a problem generically outside of the about page, open a new ticket. No videos will be on the final about page.

Note: See TracTickets for help on using tickets.