WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32132 closed defect (bug) (invalid)

Keyboard shortcut for headings (Ctrl + 1,2,3) no longer works

Reported by: silentdragoon Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Since the recent update, setting a heading level when writing a blog using Ctrl + 1, 2, 3, etc no longer works. Instead, it has reverted to the native Chrome implementation of switching to that tab number.

Running latest Windows 10, latest Chrome, WordPress 4.2.

Expected behaviour: Ctrl + 2 changes highlighted text to <h2>
Actual behaviour: Ctrl + 2 changes to the second tab in Chrome

Change History (5)

#1 @iseulde
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version changed from trunk to 4.2

Instead, it has reverted to the native Chrome implementation of switching to that tab number.

That's the reason it's changed. We should not override native shortcuts. The shortcuts are now ctrl+alt for Mac, shift+alt for Windows.

Last edited 5 years ago by iseulde (previous) (diff)

#2 follow-up: @silentdragoon
5 years ago

Seems to be Ctrl + Alt on Windows 10? Shift + Ctrl does nothing.

#3 in reply to: ↑ 2 @iseulde
5 years ago

Replying to silentdragoon:

Seems to be Ctrl + Alt on Windows 10? Shift + Ctrl does nothing.

shift+alt, sorry. I updated the comment.

#4 @silentdragoon
5 years ago

Gotcha. Thanks for the rapid response.

#5 @nacin
5 years ago

I for one am really happy for this change. I use Cmd + number as my primary way of navigating through what is usually dozens of Chrome tabs (currently 56). Whenever the visual editor (which I use almost exclusively) has the focus, I end up setting a heading style, or worse, an <address> (Cmd + 9 until 4.2).

While I've thought about removing the shortcut for <address> since it is such an edge case, I've hesitated to change this entirely in core for years because I know enough to recognize that we don't design software for me and other advanced users. My use of WordPress and my browser is not necessarily indicative of everyone else's use. In fact, it's almost certainly not indicative of everyone else's use. We don't have an easy way to see if a lot of people used these shortcuts for headings, and if a lot of people would prefer to use them in Chrome like me. Anyway, something else and someone else instigated the change — so I'm happy to roll with it and I'm glad the software works a little better for me. :-)

Note: See TracTickets for help on using tickets.