WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#32252 closed defect (bug) (duplicate)

wp-emoji makes my site unusuable on IE10 (with temporary fix included)

Reported by: jobst Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Formatting Keywords:
Focuses: ui, performance Cc:

Description

Hi

I wish you would put a setting somewhere to disable emoji - would be a very simple fix - lots of other softwares do!

The problem that I have most of our customers use IE10 on our online learning site and this is the problem - they cannot access.

System: WP 4.2.1, Karma 4.3, LATEST of woocommerce, sensei, wishlist, tiny-mc and a few self-made plugin that do not do any display work.

I cannot use IE 10, it comes up with an error message "Unable to get property 'childnodes' of undefined or null reference, this is right at the beginning of building the source code to display the site.

Now, I am not good at IE and debugging ... so I am afraid I am of no help - however it seems it comes to a grinding hold in "grabAllTextNodes" ...

Further, it would be good if you include an UN-MINIFIED version of the release file, would make debugging quicker and I do not need to build the file.

However, when I exclude the loading of the "wp-emoji-release.min.js" file in formatting.php (line 4161) then everything loads ok.

Jobst

Change History (2)

#1 @pento
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 4.2.1 to 4.2

Duplicate of #32109.

#2 @jobst
6 years ago

Thank you for fixing this!
Thank you for adding the debugging mechanism for the emoji scripts as well.
Thank you for listening!

Jobst

Note: See TracTickets for help on using tickets.