WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#32325 closed defect (bug) (fixed)

Media Library Bulk Select button size should be smaller

Reported by: afercia Owned by: afercia
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords: has-patch
Focuses: ui, javascript Cc:

Description

In the Media Library grid, the Bulk Select button is larger than default ones and a bit misaligned. See the screenshot below, compared with the button in the list mode which is perfectly aligned with other elements.

https://cldup.com/mc6rL6OGaL.png

wp.media.view.Button has a large size by default but in some cases it should be set to the default size.

Attachments (1)

32325.patch (3.0 KB) - added by afercia 6 years ago.

Download all attachments as: .zip

Change History (6)

@afercia
6 years ago

#1 @afercia
6 years ago

The proposed patch tries to set the correct size for the Bulk Select button. Please see also #32324 maybe the two patches should be merged.

Not sure this is the best way to fix the button size, it's the only one I could think of :) in the edit view the button has now the default size, while in the select view the "Cancel Selection" and "Delete Selected" buttons are still "large". Also, tried to avoid a small "jump" of the grid caused by the toolbar different height when toggling edit/select modes.

https://cldup.com/BaIUFXok1J.png

#2 @afercia
6 years ago

  • Keywords has-patch added

#3 @afercia
6 years ago

  • Milestone changed from Awaiting Review to 4.3
  • Owner set to afercia
  • Status changed from new to assigned

This ticket was mentioned in Slack in #design by afercia. View the logs.


6 years ago

#5 @wonderboymusic
6 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 32862:

Media Library Bulk Select button size should be smaller.

Props afercia.
Fixes #32325.

Note: See TracTickets for help on using tickets.