WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32382 closed defect (bug) (duplicate)

Drag and drop in admin screens not working correctly.

Reported by: eltobiano Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Widgets Keywords:
Focuses: javascript, administration Cc:

Description

Whilst debugging an issue for one of our members on WPMU DEV, I found this glitch.
The problem can be seen in Dashboard and Appearance->Widgets screens.
If there are too many admin notification messages on top -or any other element rendered on top-, the vertical dragging is limited -or even not possible-.

Steps to reproduce:

  • Add admin notifications until you can see the problem.
  • The more space that notification messages takes on top, the more limited is the vertical dragging to the bottom.

The cause of the issue is the argument 'containment' set to 'document' in the initialization of the sortable plugin.

Changing this:

containment: 'document'

Into any of this variants:

containment: $('.wrap')[0]
containment: '.wrap'

should fix the problem.

Change History (2)

#1 @ocean90
5 years ago

  • Component changed from Administration to Widgets
  • Focuses ui removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 4.2.2 to 4.2

Hello eltobiano, welcome to Trac.

Thanks for your report, but it's a duplicate of #32094.

#2 @eltobiano
5 years ago

Thanks @ocean90 and sorry for the duplicated. Tried to find the bug report before creating a new one with no avail.
The other ticket doesn't mention the issue on the Dashboard screen, so I added the information there. :)
Cheers.

Note: See TracTickets for help on using tickets.