WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#32596 closed defect (bug) (invalid)

Not creating child pages

Reported by: jbbaab44 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Permalinks Keywords: close reporter-feedback
Focuses: Cc:

Description

i am setting up a page structure 'Events > Special Events > BBQ Music Festival'
So the pages are like so:
"Events (http://www.flamingolake.com/events)"
"- Special Events (http://www.flamingolake.com/events/special-events/)"
"-- BBQ Music Festival (http://www.flamingolake.com/events/special-events/bbq-music-festival)"
The Events page is showing up. When i try to preview the 'special events' page, it redirects to the home page layout. after disabling all plugins, i tried permanently deleting these pages and then recreate them, but i still had the same issue - those pages were redirecting to the home page layout.

here is a quick video demo http://screencast.com/t/KnjfPAOfGQNl

My permalink structure is set to post name.
i have the latest version of Wordpresss
i have updated all plugins
i disabled all plugins and tested
I tested this with multiple themes. (responsive, twenty-fourteen, twenty-thirteen)
No htaccess rewrites interfering.

Change History (7)

#1 @knutsp
5 years ago

  • Component changed from General to Permalinks
  • Keywords reporter-feedback added

Using 4.3-beta, Twenty Fifteen, permalinks set to /%postname%/ and then creating a page named eventsand a sub-page of that named special-events, I am not able to reproduce this issue.

Such trouble usually resolves after flushing permalinks when visiting Settings - Permalinks. Did you try that?

#2 @jbbaab44
5 years ago

i changed permalinks to default then saved. Then i changed it back, but it did not work.
if i change the structure to default, i can see the page, but i cannot see the page if it is set to postname or custom structure (%postname%)

#3 @knutsp
5 years ago

  • Keywords dev-feedback 2nd-opinion added; reporter-feedback removed

#4 @jbbaab44
5 years ago

any update?

#5 @dd32
5 years ago

  • Keywords close reporter-feedback added; dev-feedback 2nd-opinion removed

I can't duplicate this either.
Although @jbbaab44 you've tested without plugins/themes active, can you try it on a clean install of WordPress?

#6 @knutsp
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Not able to duplicate, no feedback in three months, closing for now. Please reopen if if still a bug, and provide detailed steps to reproduce this from a clean install.

#7 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.