WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#32677 closed defect (bug) (fixed)

Customizer Menus: Accordion toggle in available menu items panel fails on first attempt after a search

Reported by: tywayne Owned by: ocean90
Milestone: 4.3 Priority: normal
Severity: normal Version: 4.3
Component: Customize Keywords: needs-patch
Focuses: Cc:

Description

Steps to reproduce:

  1. Click Add Items when editing a menu
  2. Use the search field, doesn't matter if it returns results or not.
  3. Attempt to toggle one of the accordion items below.

gif of process here: https://cloudup.com/c2w8vM4sheu

Attachments (1)

32677.diff (530 bytes) - added by tywayne 5 years ago.

Download all attachments as: .zip

Change History (4)

#1 @tywayne
5 years ago

After looking further, it appears this is happening because we're triggering debounceSearch on both the input and change events. Is there a reason we need to trigger a search on both of those events? The change event is firing when the input loses focus, thus opening the search results again.

Removing the change event in api.Menus.AvailableMenuItemsPanelView seems to fix it, but it may be there for a reason I'm not seeing.

#2 @ocean90
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.3

@tywayne
5 years ago

#3 @ocean90
5 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 32824:

Customizer: Fix keyboard events for the menu items search field.

Replace the change event with keyup, see https://core.trac.wordpress.org/ticket/26600#comment:59 for background.

props tywayne.
fixes #32677.

Note: See TracTickets for help on using tickets.