WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#32676 closed enhancement (duplicate)

A more efficient customizer (width)

Reported by: scottwyden Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: Customize Keywords:
Focuses: ui Cc:

Description

I have been thinking long and hard about the customizer and its efficiency. Since the use of the customizer is becoming a standard for themes, I think more focus needs to be put on the UI of it.

My first thought is related to the 300px size it sits in. That's very narrow for an efficient workflow. I think it could be doubled, easily.

But how to double it is the key. In my opinion, making the customizer 600px when a mouse is hovered on top of the customizer window is a smart move.

That way there is enough spacing to really see the theme options without being confined to a 300px narrow strip.

But when a mouse is moved off of the customizer, like when scrolling to see the live demo, then it can collapse down to 300px so it takes up less space.

On mobile it can also stay confined to 300px, or 50% of the screen if on an iPad in landscape.

Here is a screenshot of how 600px would look on a 15" screen: http://take.ms/s7OHU

Change History (2)

This ticket was mentioned in Slack in #core by celloexpressions. View the logs.


3 years ago

#2 @ocean90
3 years ago

  • Focuses accessibility removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32296.

Note: See TracTickets for help on using tickets.