WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#33380 closed defect (bug) (fixed)

Twenty Fifteen doesn't handle lists (ordered and non-ordered) very well inside blockquotes

Reported by: chriscct7 Owned by: SergeyBiryukov
Milestone: 4.5 Priority: normal
Severity: normal Version: 4.1
Component: Bundled Theme Keywords: good-first-bug has-patch
Focuses: administration Cc:
PR Number:

Description

There is a huge regression in 4.3 in terms of how ordered lists are handled inside block quotes

This is what it looks like:

https://dl.dropboxusercontent.com/s/pl9citd402i5y1g/Screenshot%20at%2019-22-17.png

Attachments (1)

33380.diff (310 bytes) - added by diddledan 4 years ago.
add left-margin to ul and ol elements within blockquote elements

Download all attachments as: .zip

Change History (14)

#1 @valendesigns
4 years ago

Isn't this something that is handled with CSS that the theme adds via add_editor_style()?

#2 @chriscct7
4 years ago

  • Component changed from General to Editor

#3 @chriscct7
4 years ago

  • Component changed from Editor to Bundled Theme
  • Severity changed from major to normal
  • Summary changed from 4.3 doesn't handle lists (ordered and non-ordered) very well inside blockquotes to 2015 doesn't handle lists (ordered and non-ordered) very well inside blockquotes
  • Version trunk deleted

@valendesign ah indeed. It's the 2015 theme specifically

#4 follow-up: @valendesigns
4 years ago

So the question here is whether this is an actual regression, and if it should be in the 4.3 milestone? We shouldn't add to 4.3 without discussing it first.

#5 in reply to: ↑ 4 @chriscct7
4 years ago

  • Milestone changed from 4.3 to Future Release

Replying to valendesigns:

So the question here is whether this is an actual regression, and if it should be in the 4.3 milestone? We shouldn't add to 4.3 without discussing it first.

No, its not. It was added to 4.3 when it looked like a regression in core as an editor bug. Thought I moved it to Future Release when I updated it. Oh well.

#6 @valendesigns
4 years ago

No worries.

#7 @karmatosed
4 years ago

This looks like a great ticket for patching. Anyone fancy creating one for this? You should be able to update Twenty Fifteen's editor styles and fix this.

#8 @chriscct7
4 years ago

  • Version set to 4.1

Version tag to theme release version (bug since inception as far as I could tell)

#9 @karmatosed
4 years ago

  • Summary changed from 2015 doesn't handle lists (ordered and non-ordered) very well inside blockquotes to Twenty Fifteen doesn't handle lists (ordered and non-ordered) very well inside blockquotes

#10 @SergeyBiryukov
4 years ago

  • Keywords good-first-bug added

@diddledan
4 years ago

add left-margin to ul and ol elements within blockquote elements

#11 @diddledan
4 years ago

  • Keywords has-patch added; needs-patch removed

#12 @SergeyBiryukov
4 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 36075:

Twenty Fifteen: Add left margin for lists inside blockquotes in editor-style.css.

Props diddledan.
Fixes #33380.

#13 @SergeyBiryukov
4 years ago

  • Milestone changed from Future Release to 4.5
Note: See TracTickets for help on using tickets.