WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#34056 closed defect (bug) (duplicate)

User registration email with link to generate password - link error.

Reported by: ibrythill Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.3.1
Component: Login and Registration Keywords:
Focuses: Cc:

Description

Link to generate password is surrounded by "<..>". In most Poland email hosting, the last ">" is detected as part of the link. When follow this link, the user name is not being recognised and password isn't generated.

To fix that, in pluggable.php change line 1741:

$message .= '<' . network_site_url("wp-login.php?action=rp&key=$key&login=" . rawurlencode($user->user_login), 'login') . ">\r\n\r\n";

to this:

$message .= network_site_url("wp-login.php?action=rp&key=$key&login=" . rawurlencode($user->user_login), 'login') . "\r\n\r\n";

Change History (3)

#1 @timersys
3 years ago

Realated to #23578

#2 @ibrythill
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23578.

#3 @chriscct7
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.