WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#35070 closed defect (bug) (duplicate)

Redirection loop for similar slugs with dashes

Reported by: Vikestart Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Permalinks Keywords:
Focuses: Cc:

Description

For instance, if you have the following posts:

http://www.example.com/lore/collections/kaidan-lore
http://www.example.com/lore/zone/kaidan

Trying to access either will result in an endless redirection loop. The problem is the dash between kaidan and lore, it seems that WordPress no longer recognises the rest of the slug after the dash, and thus confuses them.

When I changed it to kaidancollection instead of kaidan-lore, the redirection loop went away.

This is a new issue in WordPress 4.4.

Change History (2)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @Vikestart, welcome to Trac!

Thanks for the report, we're already tracking similar redirect issues in #35012 and #35031.

This ticket was mentioned in Slack in #core by swissspidy. View the logs.


6 years ago

Note: See TracTickets for help on using tickets.