WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#35364 closed defect (bug) (duplicate)

Mixed case siteurl causes infinite loops on static front pages

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: major Version: 4.4.1
Component: Query Keywords:
Focuses: Cc:

Description

If your siteurl is set up using mixed case characters, and your site has pretty permalinks with a static home page set, this results in an infinite loop on the front page.

All actual posts and pages will still function as expected, only front pages will result in this loop.

Looks to have first been reported in #21602, but has worked since, to be re-introduced in 4.4.1

Change History (3)

#1 @Clorith
4 years ago

  • Severity changed from normal to major

Severity bump as it does leave front pages inaccesible

#2 @azaozz
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #35353 and #35344.

#3 @BLLuten
4 years ago

Was this fixed in 4.4.2 and now it's a problem again in 4.5?

https://wordpress.org/support/topic/read-this-first-wordpress-44-master-list?replies=7&view=all#post-7857957

Maybe I'm also seeing an issue where the web.config file on IIS is not being updated correctly.

Last edited 4 years ago by BLLuten (previous) (diff)
Note: See TracTickets for help on using tickets.