Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#35369 closed defect (bug) (duplicate)

"too many redirects" error after auto upgrade to 4.4.1 from 4.4.0

Reported by: skuran's profile skuran Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.1
Component: General Keywords:
Focuses: Cc:

Description

I have 2 running WP sites behind apache load balancer. After auto update 40 4.4.1 the main page won't open with the error "too many redirects" If I set the website not to use LB and locally serve files, the error disappears. Something broke load balanced wp installations in 4.4.1

Change History (7)

#1 follow-up: @kraftbj
8 years ago

Howdy @skuran and welcome! Thanks for the report.

When the load balancer is on, can you watch the traffic (e.g. via Chrome's/Firefox's Inspector) and see what URLs is it bouncing between?

It sounds like it may be the same bug as #35344.

cc: @dd32

#2 @Clorith
8 years ago

I'd also like to chime in since we also have #35364 which relates to front page infinite loops, just in case, as #35344 related to pagination links.

#3 in reply to: ↑ 1 @skuran
8 years ago

Replying to kraftbj:

Howdy @skuran and welcome! Thanks for the report.

When the load balancer is on, can you watch the traffic (e.g. via Chrome's/Firefox's Inspector) and see what URLs is it bouncing between?

It sounds like it may be the same bug as #35344.

cc: @dd32

I created a test 4.4.1 wp site to test load balance. If accessed through the balancer main page stops with error "too many redirects" but interestingly the other posts are OK. If accessed directly front page is OK. If I turn developer tools on (google chrome) all I get is GET http://test.example.com/ net::ERR_TOO_MANY_REDIRECTS

#4 @dd32
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @skuran

Can you provide some details on your setup? What exactly makes it fail when being called through the LB vs being called directly?

It's probably something to do with how you're proxying the request URL to the hosts, and understanding what's changed there will help.

Ultimately the root cause is the same as #35344 & is another case of #35364

I'm marking this as a duplicate for tracking purposes, but you can still reply here with your setup details.

#5 @skuran
8 years ago

apache load balancer config is pretty standard. Only 1 balance member node. lb1.example.com is behind the LB and is also a virtual host and can be accessed directly through internal network.

LB config:
#################### lb.example.com 80 LB begin ####################
<VirtualHost *:80>

ServerName lb.example.com
ErrorLog logs/lb.example.com-error_log
CustomLog logs/lb.example.com-access_log combined
ProxyRequests off
<Proxy balancer://TESTcluster>

BalancerMember http://lb1.example.com:80
ProxySet lbmethod=byrequests
Order Deny,Allow
Deny from none
Allow from all

</Proxy>
ProxyPass / balancer://TESTcluster/

</VirtualHost>
#################### lb.example.com 80 end #####################

#6 @dd32
8 years ago

If you're indeed using an uppercase character in your site URL, then it's a duplicate of #21602 and will be fixed in 4.4.2.

#7 @skuran
8 years ago

Fixed in 4.4.2

Thanks.

Note: See TracTickets for help on using tickets.