WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 8 months ago

#35595 closed defect (bug) (duplicate)

No way to prevent 'rel="attachment wp-att-xxx"' from being added to all images

Reported by: pputzer Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4
Component: Media Keywords: has-patch
Focuses: Cc:

Description

The resolution of #32074 means that all images get rel="attachment wp-att-XXX" added to their markup in get_image_send_to_editor. While I am not sure if this rel is actually used for something, there should at least be a filter to preserve the previous behavior.

While I can of course add (another) filter to image_send_to_editor, there is currently no $rel for this filter (unlike $url).

Change History (4)

#1 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @pputzer, sorry we missed the ticket.

Going to close as a duplicate of #36084, which has a patch.

This ticket was mentioned in PR #437 on WordPress/wordpress-develop by mihdan.


9 months ago

  • Keywords has-patch added

As previously mentioned in comment:1:ticket:35595, the image_send_to_editor filter accepts all the parameters of get_image_send_to_editor(), except for $rel.
This seems like an oversight, it would be helpful if $rel was passed too.

Trac ticket: https://core.trac.wordpress.org/ticket/50765

Note: See TracTickets for help on using tickets.