WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#35653 closed defect (bug) (duplicate)

Calling `load_plugin_textdomain( 'textdomain' )` shouldn't cause an extra file stat call

Reported by: dd32 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: Cc:

Description

Thanks to WordPress.org Language packs, plugins no longer need to ship with translations nor a languages directory.

However, if a plugin simply calls load_plugin_textdomain( 'textdomain' ); it causes WordPress to look for WP_PLUGINS_DIR/textdomain-locale.mo.

I think we should be able to avoid looking for a translation file in this case.

Change History (3)

#1 @swissspidy
3 years ago

See also: #34213

#3 @ocean90
3 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #34213.

Note: See TracTickets for help on using tickets.