WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 3 months ago

#3567 closed enhancement (duplicate)

Synchronize options for functions that display lists

Reported by: Randy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Template Keywords: needs-patch
Focuses: Cc:

Description

It would be nice if wp_list_cats, get_archives, wp_list_pages, etc, all had "format" and "before" and "after" options :)

Attachments (2)

3567.author-template.php.diff (4.4 KB) - added by rob1n 7 years ago.
wp_list_authors()
3567.category-template.php.diff (7.9 KB) - added by rob1n 7 years ago.
wp_list_categories() and Walker_Category

Download all attachments as: .zip

Change History (23)

comment:1 ryan7 years ago

  • Owner changed from anonymous to ryan

Agreed.

comment:2 ryan7 years ago

  • Keywords hit-list added

comment:3 rob1n7 years ago

  • Owner changed from ryan to rob1n
  • Status changed from new to assigned

comment:4 foolswisdom7 years ago

  • Milestone changed from 2.2 to 2.3

rob1n7 years ago

wp_list_authors()

rob1n7 years ago

wp_list_categories() and Walker_Category

comment:5 rob1n7 years ago

  • Status changed from assigned to new

comment:6 rob1n7 years ago

  • Status changed from new to assigned

What do we want to unify? I'm thinking:

  • 'before' - before each item
  • 'after' - after each item
  • 'format' - 'html' => <ul><li></li></ul>, etc, anything else is just $before . $whatever . $after.

comment:7 rob1n7 years ago

Add 'echo' (true|false) to that list, too.

comment:8 rob1n7 years ago

  • Status changed from assigned to new

comment:9 markjaquith7 years ago

(In [5624]) Allow wp_list_authors() to optionally return. fixes #4323. see #3567.

comment:10 foolswisdom7 years ago

  • Milestone changed from 2.3 to 2.4 (next)

comment:11 rob1n6 years ago

  • Owner rob1n deleted

comment:12 ffemtcj6 years ago

  • Milestone changed from 2.5 to 2.6

comment:13 thee176 years ago

  • Owner set to thee17
  • Status changed from new to assigned

comment:14 thee176 years ago

  • Milestone changed from 2.6 to 2.7

comment:15 thee176 years ago

  • Owner thee17 deleted
  • Status changed from assigned to new

comment:16 matt6 years ago

  • Milestone changed from 2.7 to 2.9

comment:17 Denis-de-Bernardy5 years ago

  • Keywords dev-feedback 2nd-opinion added; hit-list removed

still current?

comment:18 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added; dev-feedback removed

i guess it is... wp_list_categories() among others

comment:19 Denis-de-Bernardy5 years ago

  • Keywords 2nd-opinion removed

comment:20 Denis-de-Bernardy5 years ago

  • Milestone changed from 2.9 to Future Release

comment:21 johnbillion3 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4969.

Note: See TracTickets for help on using tickets.