WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#35752 closed defect (bug) (duplicate)

Quote in term name create duplicat term

Reported by: nicolasrenard Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Taxonomy Keywords:
Focuses: Cc:

Description

When you use wp_insert_term function and term has quote in his name. It creates duplicate term.

To reproduce the issue:

Create term with wp_insert_term( "test d'un terme", "your-taxonomy-slug" )

Each time the function is called a new term will be created.

Change History (3)

#1 in reply to: ↑ description @nicolasrenard
5 years ago

Same issue in back-office :

  • add termok end term'ok as name in a taxonomy
  • add again termok: an error is displayed for term already exists
  • add again term'ok: a new term is added with same name

Replying to nicolasrenard:

When you use wp_insert_term function and term has quote in his name. It creates duplicate term.

To reproduce the issue:

Create term with wp_insert_term( "test d'un terme", "your-taxonomy-slug" )

Each time the function is called a new term will be created.

Last edited 5 years ago by nicolasrenard (previous) (diff)

#2 @nicolasrenard
5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #35493.

#3 @swissspidy
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.