WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#35872 closed defect (bug) (duplicate)

Restore this revision functionality

Reported by: jasonrweed Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.4.2
Component: Revisions Keywords:
Focuses: ui, administration Cc:
PR Number:

Description

I had an auto-save of a (published) page. My kids shut off the computer. I started everything up again and went to my page in WP. I went to revisions and clicked "restore this revision" - the auto-saved version.

I expected the page to reload with the auto-saved version in the Editor, ready to Preview or Publish.

But, instead it loaded the auto-saved version in the Editor AND Published it automagically. (Presumably because the page had indeed been published before - just not with my auto-saved version)

Change History (1)

#1 @adamsilverstein
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@jasonrweed - Thanks for your bug report!

Indeed, you are not the first person to think something different should happen when you click the 'Restore this Revision' button - namely restoring the content to the editor instead of to the published state.

Closing this as a duplicate of #27244.

Note: See TracTickets for help on using tickets.