WordPress.org

Make WordPress Core

#36484 closed defect (bug) (maybelater)

Bump Recommended PHP version to PHP 7

Reported by: jorbin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: docs Cc:

Description

Follow up to #33758

PHP 7 has been released for 4 months now and there have been no major issues with running WordPress on. Let's bump the recommended version of PHP to continue encouraging people to run the latest and greatest PHP.

Once we decide to do it, a meta ticket will need to be opened to update things on WordPress.org

Change History (11)

#1 @mikeschroder
20 months ago

FWIW, this has my +1.

#2 @ocean90
20 months ago

Noting that Tests_External_HTTP_Basis is using https://secure.php.net/supported-versions.php which would fail in 8 months I think.

#3 @knutsp
20 months ago

I/we run PHP 7 on most of my (client) sites (60) and see no reason this should not be the recommended version from now on.

#4 @blobaugh
20 months ago

I like it! I have not run into any issues with PHP 7 in a few months. Was running a beta before that had issues that seem to be ironed out.

#5 @pento
19 months ago

On the Tests_External_HTTP_Basis test, that's only for when we must updated the recommended version, there's no problem with updating it earlier.

While Core hasn't had any PHP 7 problems, are there any plugins with issues? The recommended PHP version should probably take the entire ecosystem into account.

#6 @rmccue
19 months ago

+1, especially given that the PHP team tests PHP against WordPress itself during development. Our experience with migrating to PHP 7 has had ~0 breakage in plugins, apart from warnings on PHP 4-style constructors.

#7 @jeremyfelt
19 months ago

+1 and, FWIW, VVV's develop branch is now PHP 7.0. This should be part of the next stable release at the end of May.

#8 follow-up: @jdgrimes
19 months ago

+1. I've migrated a couple of sites to PHP 7 without issues from core or plugins, although some plugins do give off some notices (W3TC).

#9 @mensmaximus
19 months ago

+1. No issues with 7.0 any more

#10 in reply to: ↑ 8 @pento
19 months ago

Replying to jdgrimes:

although some plugins do give off some notices (W3TC).

Given that we have until the end of the year before we have to bump it, there's no harm in holding off until major plugins are confirmed to work without notices or warnings. Until we can confirm that, I'm -1 on bumping the version for now.

This is remembering that we're talking about the recommended PHP version. The recommended version should be providing an ideal experience for folks, we shouldn't be bumping to a bigger number just because it's there.

Given the PHP 5.6 support timeline, we'll be bumping it by WordPress 4.8 at the latest, so it'd be nice to use those intervening months to ensure the UX for the wider WordPress ecosystem under PHP 7 is solid.

#11 @ocean90
19 months ago

  • Milestone Future Release deleted
  • Resolution set to maybelater
  • Status changed from new to closed

I agree with @pento here.

We shouldn't recommend PHP 7 if one of our own plugins isn't ready yet: #36281.

Note: See TracTickets for help on using tickets.