WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#36682 closed enhancement (duplicate)

More filters in the cron system, to allow more plugin interaction

Reported by: DavidAnderson Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Cron API Keywords:
Focuses: Cc:

Description

The attached patch adds two additional filters to wp-includes/cron.php.

These (when combined with the already-existing filters) should allow (amongst other things) a plugin to reliably interact with any part of WP's cron system, which currently is not possible (or only possible with gross hacks, such as filtering on options loading of the 'cron' option).

This includes the possibility for a plugin to store the cron events in a different storage mechanism entirely (i.e. store in a separate table, instead of a single serialized options array). Various plugins which rely upon reliable more cron events than the race-y system already implement their own systems externally (e.g. see some of the discussion here: https://github.com/woothemes/woocommerce/issues/3467 ), so there is certainly demand for this.

Attachments (1)

cron-hooks.diff (1.4 KB) - added by DavidAnderson 3 years ago.
Documented patch adding two filters to wp-includes/cron.php

Download all attachments as: .zip

Change History (4)

@DavidAnderson
3 years ago

Documented patch adding two filters to wp-includes/cron.php

#1 @dd32
3 years ago

@rmccue Can you review this, considering you've got experience here?

#2 @rmccue
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32656.

This ticket was mentioned in Slack in #core-multisite by greatislander. View the logs.


2 years ago

Note: See TracTickets for help on using tickets.