WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 20 months ago

#36884 closed defect (bug) (fixed)

Customizer child menus incorrectly resize the site to an incorrect minimum-width

Reported by: kwonye Owned by: adamsilverstein
Milestone: 4.9.5 Priority: normal
Severity: normal Version: 4.4
Component: Customize Keywords: has-patch commit fixed-major
Focuses: ui, administration Cc:
PR Number:

Description

On Chrome for Android, creating a child menu in the Customizer expands the width of the page to a min-width: 950px, !important (at least on my device)

Repro steps:

1) Go to dashboard > Themes >Customize.
2) Go to Menus > click 'Add a Menu' > Create Menu
3) Add Items (at least two) and back out
4) Drag one of the items to the right to be a child menu.
5) Screen resizes

Attachments (4)

test-menu-1-v11.png (53.6 KB) - added by kwonye 3 years ago.
test-menu-1-v21.png (30.6 KB) - added by kwonye 3 years ago.
36884.diff (377 bytes) - added by adamsilverstein 3 years ago.
36884.2.diff (405 bytes) - added by adamsilverstein 21 months ago.

Download all attachments as: .zip

Change History (21)

#1 @adamsilverstein
3 years ago

Hello @kwonye, thanks for the bug report!

Can you give some more details about your device, what is the specific model/version? Also, if possible please add a screenshot showing what you see when this issue occurs.

Thanks!

#2 @lukecavanagh
3 years ago

Could this not be fixed by being able to resize the customizer pane?

#3 @kwonye
3 years ago

@adamsilverstein

Happened on two devices:

Device: Samsung Galaxy S6 Edge+
Android version: 5.1.1

Device: Nexus 6P
Android version: 6.0.1

(also, images attached)

Last edited 3 years ago by kwonye (previous) (diff)

#4 @adamsilverstein
3 years ago

In 36884.diff :

Ensure body min width not applied when editing menus in customize; fixes an issue where screen resized to an oversize state on mobile devices when adding sub-menus.

#5 @adamsilverstein
3 years ago

  • Keywords has-patch needs-testing added

Screencasts:

Before:

http://cl.ly/3U1j3u1d3Q31/Screen%20Recording%202016-05-20%20at%2007.55%20AM.gif

After:

http://cl.ly/2D3E3G2j3s2G/Screen%20Recording%202016-05-20%20at%2007.56%20AM.gif

#6 follow-up: @adamsilverstein
3 years ago

  • Owner set to adamsilverstein
  • Status changed from new to assigned
  • Version changed from 4.5.2 to 4.4

@kwonye thanks again for raising this issue; the patch I attached fixes it, can you give it a test? Pretty sure this issue has existed since we introduced menus in the customizer in WordPress 4.4.

Last edited 3 years ago by adamsilverstein (previous) (diff)

#7 in reply to: ↑ 6 @kwonye
3 years ago

Replying to adamsilverstein:

@kwonye thanks again for raising this issue; the patch I attached fixes it, can you give it a test? Pretty sure this issue has existed since we introduced menus in the customizer in WordPress 4.4.

Fix looks great, thanks @adamsilverstein!

#8 @adamsilverstein
21 months ago

Thanks for confirming @kwonye - I'm going to-test this to see if its still and iss and if the fix still works.

#9 @adamsilverstein
21 months ago

  • Keywords commit added; needs-testing removed
  • Milestone changed from Awaiting Review to 4.9.5

Confirmed the issue still exists and the patch still fixes it. refreshed against trunk in 36884.2.diff.

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


21 months ago

#11 @adamsilverstein
21 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 42817:

Customizer menus: correct oversized viewport after dragging menu items.

Fix an issue where the screen viewport resized to an oversized state on mobile devices after moving sub-menus.

Props kwonye.
Fixes #36884.

#12 @adamsilverstein
21 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for 4.9.5 consideration.

This ticket was mentioned in Slack in #core by danieltj. View the logs.


20 months ago

#14 @audrasjb
20 months ago

Hello,

This ticket was mentioned during 4.9.5 bug scrub.
I tested the patch and it seems ready to land in 4.9.5.

#15 @audrasjb
20 months ago

  • Keywords fixed-major added

This ticket was mentioned in Slack in #core by audrasjb. View the logs.


20 months ago

#17 @ocean90
20 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 42850:

Customizer menus: correct oversized viewport after dragging menu items.

Fix an issue where the screen viewport resized to an oversized state on mobile devices after moving sub-menus.

Merge of [42817] to the 4.9 branch.

Props adamsilverstein, kwonye.
Fixes #36884.

Note: See TracTickets for help on using tickets.