WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#37421 closed defect (bug) (invalid)

URL / Permalink still existing

Reported by: doeringjuergen Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Permalinks Keywords:
Focuses: Cc:

Description

URL / Permalink still existing:
Hi I have a strange bug in my WP Blog: I have erased the side
http://www.informiert.wer-den.de/urlaubs-codex/
but the URL shows now all my sides form this WP installation (see picture enclosed) it is not possible to create a new side under this permalink …
I use the newest WP version 4.5.3 and I have deactivated all plugins but no help … and of course the side is permanently erased …
what is the solution to solve this bug?

Attachments (1)

Page informiert.wer-den.de urlaubs-codex.JPG (147.3 KB) - added by doeringjuergen 4 years ago.

Download all attachments as: .zip

Change History (9)

#1 follow-up: @justingreerbbi
4 years ago

When you refer to "the side" are you talking about the sidebar or the page/post itself? I am not fully understanding what you are referring to.

  • Posted before you added photos
Last edited 4 years ago by justingreerbbi (previous) (diff)

#2 in reply to: ↑ 1 @knutsp
4 years ago

Replying to justingreerbbi:

When you refer to "the side" are you talking about the sidebar or the page/post itself?

I'm quite sure "side" means page.

#3 @justingreerbbi
4 years ago

@doeringjuergen

I am unable to replicate the issue with a a fresh copy of 4.5.3. Here are the steps I used to test:

  • Create page titled "Test Page" (slug was test-page)
  • Visited /wp-admin/edit.php?post_type=page and deleted the page
  • Visited the trash /wp-admin/edit.php?post_status=trash&post_type=page and clicked "Empty Trash"
  • Recreated a page called "Test Page". WordPress allowed me to use the old slug.

Are you sure you are removing the post completely from the trash? Also ensure that there are no other pages with that slug that are active. This would go for posts as well.

#4 @doeringjuergen
4 years ago

Hi yes side means page ... and i mean the page itself... see the link:
http://www.informiert.wer-den.de/urlaubs-codex/
this page should not display all my pages... as the page do not exist any more!

#5 @justingreerbbi
4 years ago

I don't think you mean page itself. I think you mean the menu link to the page is showing even though it does not exists. Ensure that the link is not set in your widgets and or menus under "Appearance" in WP admin.

#6 @knutsp
4 years ago

  • Keywords close added

Hello and welcome to Trac!

You have an attachment named Urlaubs-Codex.pdf. The page you see is the attachment page for this file.

This is not a bug in WordPress. Please get better help on our support forums https://wordpress.org/support/

#7 @doeringjuergen
4 years ago

  • Keywords close removed

Are you sure you are removing the post completely from the trash? Also ensure that there are no other pages with that slug that are active. This would go for posts as well.

Yes I am sure .... we check all ....

#8 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please try the support forums for troubleshooting: ​https://wordpress.org/support/ or https://de.forums.wordpress.org/.

Feel free to reopen with steps to reproduce on a clean install if it turns out to be a bug in core.

Note: See TracTickets for help on using tickets.