Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#37465 closed enhancement (duplicate)

Remove UTC options from timezone if not selected + filter to restore

Reported by: pbearne Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.5.3
Component: Date/Time Keywords:
Focuses: Cc:

Description

To solve the problem where the option "timezone_string" is not set because an UTC offset has been selected.

This patch remove the UTC options if not currently selected.

It also adds a filter ("show_utc_offsets") to allow the UTC offsets to be restored for a site

Includes Unit Tests

Attachments (2)

wp_timezone_choice.patch (3.6 KB) - added by pbearne 6 years ago.
patch
wp_timezone_choice.2.patch (3.8 KB) - added by pbearne 6 years ago.
add docblock to fliter

Download all attachments as: .zip

Change History (6)

@pbearne
6 years ago

patch

#1 @SergeyBiryukov
6 years ago

Duplicate of #36591?

Related: #10660, #18146, #29205.

@pbearne
6 years ago

add docblock to fliter

#2 @pbearne
6 years ago

yes duplicate of #36591 shall close this and add patch to #36591?

#3 @pbearne
6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #36591.

#4 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.