WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#37538 closed defect (bug) (duplicate)

Multisite: marking a sub-site subscriber as spam marks the entire sub-site as spam.

Reported by: imath Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: Users Keywords: has-patch
Focuses: multisite Cc:
PR Number:

Description

On a multisite configs, i think the site owner of a sub-site can be "responsible" of the behavior of his contributors, but i think it's a bit severe to also make him "responsible" of his subscribers behavior.

Today when the Network administrator spams a user all the sites he has a role on will be marked has spam. I think WordPress should only do this if the role of the user is at least a contributive role.

Subscribers has the same impact on content than regular visitors: they can comment. So i'd suggest the attach patch.

Attachments (1)

37538.diff (3.0 KB) - added by imath 3 years ago.

Download all attachments as: .zip

Change History (3)

@imath
3 years ago

#1 @imath
3 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #20774.

Note: See TracTickets for help on using tickets.