Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#37918 closed defect (bug) (duplicate)

wp_remote_get skips first line under some cirumstances

Reported by: tastenchris Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6
Component: HTTP API Keywords:
Focuses: Cc:

Description

I am using a WP plugin called "amr event lists with ical files" to display an event list from a google calendar. The plugin uses wp_remote_get to get the calendars ics data. Under some circumstances the return value of wp_remote_get lacks the first line of the calendar ("BEGIN:VCALENDAR"). The plugins author and I tried to figure out in what circumstances this happens, but without success.
There is an example URL showing the described effect used in my WP page: https://calendar.google.com/calendar/ical/ldncnjg2a0tjv7f36p4kri9eqg%40group.calendar.google.com/public/basic.ics

Getting this URL with wget or curl results in consistent calendar data, getting it via wp_remote_get the first line is missing. This happens since WP 4.6, no problem in earlier versions.

Change History (3)

#1 @stephenharris
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #37839.

#2 @stephenharris
5 years ago

Thanks for reporting this @tastenchris - this is being tracked in #37839. It's actually a bug in library being used by WordPress (since 4.6). There's a patch for that bug, and it's now just a matter of updating the library when that patch is merged in.

Last edited 5 years ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
5 years ago

  • Component changed from General to HTTP API
Note: See TracTickets for help on using tickets.