WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#38267 closed enhancement (duplicate)

debug not reporting wp_footer() missing

Reported by: Brandora Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Themes Keywords:
Focuses: Cc:

Description (last modified by swissspidy)

hi i recently came across a problem (my fault) because i accidentally deleted wp_footer() out of the code before the ending </body> tag and one of my plugins did not function. the developer of the plugin (mihai from wpbruiser which rules btw) is the one that pointed this out to me.

i feel like if i have set wp_debug to true in the config and our theme or setup is missing the function wp_footer() in the code the debug should alert the user about this. from my perspective, i had 0 errors and thought my code was solid. however, i am new to wordpress development but i am not new to web development...coming from asp/asp.net background. if the debug mode had reported this it seems it wouldve saved me a lot of time/communication with the plugin developer which had literally nothing to do with this issue. this isnt a bug report but something i think is very important to developers working in your platform as something as simple as having the wp_footer missing seems like it would throw some errors. something to consider.

thanks,
brandon

Change History (1)

#1 @swissspidy
4 years ago

  • Component changed from General to Themes
  • Description modified (diff)
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hey there,

Thanks for your report and welcome to WordPress Trac!

I'm closing this one as a duplicate of #14752 where we're already tracking this issue. Even if that ticket is closed, discussion can continue there.

Also, I want to let you know that using such language (my code was…) is really inappropriate.

Note: See TracTickets for help on using tickets.