WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#38893 closed defect (bug) (invalid)

Cant get wordpress to update navigation label when changing original page header.

Reported by: tifure Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.6.1
Component: Menus Keywords:
Focuses: Cc:

Description

Navigation label does not update when a change is made original page header.

Attachments (2)

Skjermbilde 2016-11-20 23.42.46.jpg (67.5 KB) - added by tifure 3 years ago.
Showing original name under that is supposed to show up in the navigation label, but the field " navigation label" does not change.
Skjermbilde 2016-11-21 20.06.10.jpg (58.5 KB) - added by tifure 3 years ago.
Navigation label should be showing the same as original: Veksfag. 4-7 mai.

Download all attachments as: .zip

Change History (12)

@tifure
3 years ago

Showing original name under that is supposed to show up in the navigation label, but the field " navigation label" does not change.

#1 follow-up: @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hey there,

Welcome to WordPress Trac! This issue tracker is meant for reporting bugs and enhancements in WordPress Core. For support questions, we have dedicated support forums.

However, I just had a quick look at your website and it doesn't seem to be powered by WordPress at all. Thus, you need to ask the developer of your website about this.

@tifure
3 years ago

Navigation label should be showing the same as original: Veksfag. 4-7 mai.

#2 in reply to: ↑ 1 @tifure
3 years ago

Replying to swissspidy:

Hey there,

Welcome to WordPress Trac! This issue tracker is meant for reporting bugs and enhancements in WordPress Core. For support questions, we have dedicated support forums.

However, I just had a quick look at your website and it doesn't seem to be powered by WordPress at all. Thus, you need to ask the developer of your website about this.

sorry --- I added wrong screenshot :o) can I delete that attachment? Look at the second attachement

#3 @tifure
3 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#4 @tifure
3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

#5 @swissspidy
3 years ago

Ah, now it makes more sense. Thanks for the correct screenshot!

In WordPress, one can add posts and pages and other items to a menu. The newly added menu item references the original item, but is completely separate. This allows you to set the navigation label to anything you want. It does not update when you change the original label. That's by design, and not a bug.

If you want a way to update the navigation label when updating the post title, I recommend you to ask in the support forums in the Plugins and Hacks category.

#6 follow-up: @westonruter
3 years ago

@swissspidy I'm not sure that this isn't a bug, and I think that this issue is now fixed for nav menus in the customizer. Namely, if you add a post/page to a nav menu item, then you should be able to leave the label for the nav menu item blank and it should inherit from the title of the original post/page so that it will be updated when the underlying object's title changes.

#7 @westonruter
3 years ago

#38894 was marked as a duplicate.

#8 @swissspidy
3 years ago

@westonruter That's right, my bad. Works in the admin too if the label is the same as the post ones and the post gets updated.

@tifure So to partly revisit my statement, you should actually be able to achieve this. See the above explanation.

#9 in reply to: ↑ 6 @tifure
3 years ago

Replying to westonruter:

@swissspidy I'm not sure that this isn't a bug, and I think that this issue is now fixed for nav menus in the customizer. Namely, if you add a post/page to a nav menu item, then you should be able to leave the label for the nav menu item blank and it should inherit from the title of the original post/page so that it will be updated when the underlying object's title changes.

Thing is, only page title is changed - we dont change anything else. Is there another place there to empty text so it should "autofill" the navigation label? Please. Sorry the mess with the wrong attachment.

#10 @westonruter
3 years ago

  • Component changed from General to Menus
Note: See TracTickets for help on using tickets.