WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#39642 closed defect (bug) (duplicate)

wp_mail multipart content handling

Reported by: JeffMatson Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.8
Component: Mail Keywords: has-patch
Focuses: Cc:
PR Number:

Description

There are issues passing the boundary value in the content header, as it gets stripped out. It appears to be due to the behavior of PHPMailer.

As PHPMailer supports multipart content natively, a slight modification to wp_mail solves the issue. This would greatly simplify things, and allow for better mail handling by anyone sending via wp_mail.

Attachments (1)

multipart-mime.diff (779 bytes) - added by JeffMatson 3 years ago.
Diff for proposed solution

Download all attachments as: .zip

Change History (4)

@JeffMatson
3 years ago

Diff for proposed solution

#1 @MattyRob
3 years ago

  • Keywords has-patch added

Related to #15448

#2 @JeffMatson
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15448.

#3 @swissspidy
3 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.