Make WordPress Core

Opened 17 years ago

Closed 16 years ago

#4030 closed defect (bug) (worksforme)

unable to view password protected posts

Reported by: texmex657's profile texmex657 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1.2
Component: General Keywords: post password
Focuses: Cc:


Have been having problems with the post password for some time now. Tried to debug the issue a little bit and I upgraded to wordpress 2.1.2, applied the default theme, and deactivated all the plugins. I would then create a post with a password and pretty much everytime I would try to put in the password, the page would refresh and the post would not be shown.

I could see the cookie with the correct value when I viewed my cookies in firefox but the post could not be seen. Sometimes when I would click the category that the post was tagged with, after the cookie was correctly set, the post would be seen in the category menu, but then when going back to the main page it would sometimes not be able to be viewed again.

Similar behavior was observed in IE.

Change History (8)

#1 @texmex657
17 years ago

  • Milestone 2.3 deleted
  • Summary changed from unable to view password protected posts 95% of the time to unable to view password protected posts

#2 @rob1n
17 years ago

  • Milestone set to 2.4

#3 follow-up: @rob1n
17 years ago

  • Component changed from Security to General
  • Milestone 2.4 deleted

I believe this is more of a topic suited for the support forums, as password protected posts have been proven to work many times over. That aside, have you tried clearing cookies/cache/etc.?

#4 in reply to: ↑ 3 @texmex657
17 years ago

Yes, many times. Everytime I would load my page I would clear cache and cookies before trying anything else. Then I would enter the password, see the page refresh, verify that the cookie was created, and then start refreshing / trying the category tab to see if I could get the post to be seen.

#5 @foolswisdom
17 years ago

  • Milestone set to 2.2

We have also seen this issue on .

#6 @texmex657
17 years ago

Tried changing my hosting options as stated in this forum:

No luck though. Here were the options I had to choose from:

How do you like the www in your URL?

Both and work.

Add "www." if somebody goes to

Remove "www." if somebody goes to

#7 @foolswisdom
17 years ago

  • Milestone changed from 2.2 to 2.3

#8 @Nazgul
16 years ago

  • Milestone 2.3 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

As there are no clear reproduction steps, there hasn't been any activity for almost half a year and I can't reproduce this on my own, I'll close this one as worksforme for now.

Feel free to reopen this issue if you have any additional info/reproduction steps/...

Note: See TracTickets for help on using tickets.