WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#40550 closed defect (bug) (duplicate)

Incorrect list of Default Post Format

Reported by: mehul0810 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.7.4
Component: Post Formats Keywords:
Focuses: administration Cc:

Description

Just stumbled upon an inconsistent behaviour for Post Format.

Issue

On adding below code to after_setup_theme action hook.

    add_theme_support( 'post-formats',array( 'image', 'gallery', 'video' ) );

Then go to Settings > Writing and check the Default Post Format List. It is showing all the post formats available rather than the post formats which have been assigned using the code.

Expected to show only: Standard, Image, Gallery and Video as per the code added.

Furthermore, when we select a Default Post Format as Chat which is not added in the code. Then creating a post will show Chat Post Format default selected which is weird. Does this make sense?

Change History (2)

#1 @SergeyBiryukov
15 months ago

  • Component changed from General to Post Formats
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @mehul0810, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #34670.

Then go to Settings > Writing and check the Default Post Format List. It is showing all the post formats available rather than the post formats which have been assigned using the code.

This appears to be intentional, see comment:3:ticket:34670.

Last edited 15 months ago by SergeyBiryukov (previous) (diff)

#2 @SergeyBiryukov
15 months ago

Marking as a duplicate of #34670 (used wrong ticket number in my previous comment).

Last edited 15 months ago by SergeyBiryukov (previous) (diff)
Note: See TracTickets for help on using tickets.