WordPress.org

Make WordPress Core

Opened 2 years ago

Last modified 7 months ago

#34670 reopened defect (bug)

Default Post Format option lists formats that are not available in the theme

Reported by: carina.pilar Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 4.3.1
Component: Post Formats Keywords: close
Focuses: Cc:

Description

The problem happens when you set a post format that it's not available on the theme. It actually happened with the Canard theme, that doesn't allow Video post formats. Below is the steps to reproduce:

1) Select the Canard theme

2) On Settings > Writing, change the Default Post Format to Video

3) Add a new post, it will show the Video format post selected (even if it's not allowed). Add a Featured Image and publish the post.

The Featured Image will not show on the front page. I've tested and reproduced this behavior with WP Admin and Calypso for WordPress.com and on a self hosted site. I tried different themes and post formats, but was able to reproduce only with Video format, and found only this theme that it's not allowed.

Let me know if you need any other information.

Thanks,
Carina Pilar
Happiness Engineer Trial

Change History (7)

#1 @samuelsidler
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hello! Thanks for this report, however issues with themes aren't handled by the WordPress core team (outside of default themes that ship with WordPress). You'll need to report this to the theme author, in this case Automattic.

#2 @carina.pilar
2 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Hi samuelsidler!

Actually I opened this ticket to the WordPress core because the problem happens when I select a post format that it's not allowed. Since it's on the wp-admin, I guess it's not theme related.

#3 @ocean90
2 years ago

  • Keywords close added
  • Milestone set to Awaiting Review

The option on Writing Settings is independent from themes, you can select all post formats there. That makes sense because each theme has its own post format support. If you switch your theme you still can continue to use the selected post format.

That your theme doesn't show a featured image for video posts is probably a design decision from the theme author.

#4 @carina.pilar
2 years ago

Hi ocean90,

I see what you mean, the featured images not showing it's not the problem actually, that was the way I found that. The problem is, if I have a theme that only allows 4 format types, when I add a new post wpadmin only shows the allowed ones. It didn't let me choose one that it's now allowed. But, if I choose one on Writing Settings that it's not allowed, when I add a new post wpadmin doesn't make this validation, it lets me add a post with a format that it's not allowed. What I want to say, that at one point it validates, but in other way it doesn't.

I don't know if I could make myself clear, if you need any other information we can chat on Slack. :)

#6 @SergeyBiryukov
7 months ago

  • Summary changed from Selecting Unavailable Post Formats Hides Featured Images to Default Post Format option lists formats that are not available in the theme

#7 @SergeyBiryukov
7 months ago

#40550 was marked as a duplicate.

Note: See TracTickets for help on using tickets.